HELP I'M SO LOST

Discuss any issues with Denizen-Bukkit scripts or functionality you may have while using it.
Post Reply
Csstform
New
New
Posts: 4
Joined: February 27th, 2018, 11:46 pm

HELP I'M SO LOST

Post by Csstform » February 27th, 2018, 11:50 pm

I can't seem to make heads or tails of this language, or how it works. I've tried multiple tutorials, and none of them seem to apply anymore, as well as the documentation doesn't make any sense. Could someone help me out on simply getting my NPCs to talk?

https://hastebin.com/osibesocox.scala

User avatar
mcmonkey
Site Admin
Site Admin
Posts: 173
Joined: August 5th, 2016, 7:27 pm
Location: Los Angeles, California, USA
Contact:

Re: HELP I'M SO LOST

Post by mcmonkey » February 27th, 2018, 11:57 pm

Video tutorials are at https://one.denizenscript.com/denizen/vids

Main support line is live text chat at https://discord.gg/Q6pZGSR

That script doesn't look like it should fail to work but is visibly off-standard for modern setups, and might have some oddities causing it to fail. If you can't figure it out, post some error logs or similar here or on Discord for help figuring out what went wrong.
Denizen lead developer.
http://mcmonkey.org

Csstform
New
New
Posts: 4
Joined: February 27th, 2018, 11:46 pm

Re: HELP I'M SO LOST

Post by Csstform » February 28th, 2018, 7:21 am

mcmonkey wrote:Video tutorials are at https://one.denizenscript.com/denizen/vids

Main support line is live text chat at https://discord.gg/Q6pZGSR

That script doesn't look like it should fail to work but is visibly off-standard for modern setups, and might have some oddities causing it to fail. If you can't figure it out, post some error logs or similar here or on Discord for help figuring out what went wrong.
Yes, those videos are the ones I've been looking through. Even if I copy the script in the video verbatim (which each set of videos does it slightly differently of course), it doesn't seem to work - it's not erroring as far as I can tell, it just doesn't do anything. Did I miss a step where I had to activate a permission or something?

User avatar
mcmonkey
Site Admin
Site Admin
Posts: 173
Joined: August 5th, 2016, 7:27 pm
Location: Los Angeles, California, USA
Contact:

Re: HELP I'M SO LOST

Post by mcmonkey » February 28th, 2018, 7:30 am

Csstform wrote:
mcmonkey wrote:Video tutorials are at https://one.denizenscript.com/denizen/vids

Main support line is live text chat at https://discord.gg/Q6pZGSR

That script doesn't look like it should fail to work but is visibly off-standard for modern setups, and might have some oddities causing it to fail. If you can't figure it out, post some error logs or similar here or on Discord for help figuring out what went wrong.
Yes, those videos are the ones I've been looking through. Even if I copy the script in the video verbatim (which each set of videos does it slightly differently of course), it doesn't seem to work - it's not erroring as far as I can tell, it just doesn't do anything. Did I miss a step where I had to activate a permission or something?
Basically anything you try to do in Denizen will either give very explicit and useful debug output (until you disable debug for the relevant section) or an error. If you got neither of them... you're missing multiple steps that you need to do.
Denizen lead developer.
http://mcmonkey.org

Csstform
New
New
Posts: 4
Joined: February 27th, 2018, 11:46 pm

Re: HELP I'M SO LOST

Post by Csstform » February 28th, 2018, 7:40 am

mcmonkey wrote:
Csstform wrote:
mcmonkey wrote:Video tutorials are at https://one.denizenscript.com/denizen/vids

Main support line is live text chat at https://discord.gg/Q6pZGSR

That script doesn't look like it should fail to work but is visibly off-standard for modern setups, and might have some oddities causing it to fail. If you can't figure it out, post some error logs or similar here or on Discord for help figuring out what went wrong.
Yes, those videos are the ones I've been looking through. Even if I copy the script in the video verbatim (which each set of videos does it slightly differently of course), it doesn't seem to work - it's not erroring as far as I can tell, it just doesn't do anything. Did I miss a step where I had to activate a permission or something?
Basically anything you try to do in Denizen will either give very explicit and useful debug output (until you disable debug for the relevant section) or an error. If you got neither of them... you're missing multiple steps that you need to do.
I see now... it shows when I reload the scripts, whoops. It's throwing an error when I declare the interact scripts.
https://i.imgur.com/nRsI8fi.png

User avatar
mcmonkey
Site Admin
Site Admin
Posts: 173
Joined: August 5th, 2016, 7:27 pm
Location: Los Angeles, California, USA
Contact:

Re: HELP I'M SO LOST

Post by mcmonkey » February 28th, 2018, 7:42 am

I noticed really late but your script posted earlier is broken a bit:

Code: Select all

Jack_Daniels:
	type: assignment
		interact scripts:
			- 1 Jack_Daniels_interact
the interact scripts block should not be tabbed out further than the type.

Can probably apply the same fix to whatever your current script is.
Denizen lead developer.
http://mcmonkey.org

Csstform
New
New
Posts: 4
Joined: February 27th, 2018, 11:46 pm

Re: HELP I'M SO LOST

Post by Csstform » February 28th, 2018, 7:48 am

Thanks, that got it working.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest