dDiscordbot Issues

Discuss any issues with Denizen-Bukkit scripts or functionality you may have while using it.
Post Reply
n0nnie
New
New
Posts: 31
Joined: January 10th, 2018, 3:19 am
Location: München - Germany
Contact:

dDiscordbot Issues

Post by n0nnie » August 25th, 2020, 10:34 pm

I am having a hard time to get my Discordbot back online.

Everytime I start up the Server the bot will not connect and errorlog shows me this (besides of many script errors, because Bot is not connected)
Spoiler!
[07:24:33] [Thread-22/WARN]: Exception in thread "Thread-22"
[07:24:33] [Thread-22/WARN]: java.lang.NoClassDefFoundError: org/slf4j/Logger
[07:24:33] [Thread-22/WARN]: at com.denizenscript.shaded.net.dv8tion.jda.internal.utils.IOUtil.<clinit>(IOUtil.java:35)
[07:24:33] [Thread-22/WARN]: at com.denizenscript.shaded.net.dv8tion.jda.api.JDABuilder.build(JDABuilder.java:1829)
[07:24:33] [Thread-22/WARN]: at com.denizenscript.ddiscordbot.DiscordCommand$DiscordConnectThread.run(DiscordCommand.java:218)
[07:24:33] [Thread-22/WARN]: Caused by: java.lang.ClassNotFoundException: org.slf4j.Logger
[07:24:33] [Thread-22/WARN]: at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
[07:24:33] [Thread-22/WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:167)
[07:24:33] [Thread-22/WARN]: at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:96)
[07:24:33] [Thread-22/WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
[07:24:33] [Thread-22/WARN]: at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
[07:24:33] [Thread-22/WARN]: ... 3 more

What I tried so far:
Updated to:
dDiscordBot-0.6-b100.jar
Denizen-1.1.6-b5048-DEV.jar
Depenizen-2.0.0-b657.jar

Updated to latest Spigot Version
[07:28:08] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-d65430a-bad55db (MC: 1.16.2)

Kicked the Bot from my Discordserver and invited it back with Administratorpermissions.

The script I am using to handle the bot:

Code: Select all

discord_listener:
    type: world
    events:
        on server start:
        - yaml load:data/Discord_Chat_Relay_Config.yml id:discord_chat_relay_temp
        - discord id:mybot connect code:<yaml[discord_chat_relay_temp].read[bots.discord.botToken]>
        - discord id:mybot message channel:<yaml[discord_chat_relay_temp].read[bots.discord.channel.Botchat]> "Server gestartet"
Please help me, I am lost. I think I have something overlooked but I can not handle this by myself. Thank you in advance

User avatar
mcmonkey
Site Admin
Site Admin
Posts: 299
Joined: August 5th, 2016, 7:27 pm
Location: Los Angeles, California, USA
Contact:

Re: dDiscordbot Issues

Post by mcmonkey » August 26th, 2020, 7:28 am

You're literally asking for help with Discord while not on the Denizen Discord??? https://discord.gg/Q6pZGSR
Denizen lead developer. On Discord as mcmonkey#6666.

n0nnie
New
New
Posts: 31
Joined: January 10th, 2018, 3:19 am
Location: München - Germany
Contact:

Re: dDiscordbot Issues

Post by n0nnie » August 26th, 2020, 11:21 pm

Sorry, I was not aware, that I have to be in Discord to ask for support in this Issues Section. I changed that.

Thank you for the newest Build for ddiscordbot, all is working now again.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest